网站首页 程序人生 资源汇 学建站 源码 织梦模板 特效代码 技术手册 IT头条 电商 创业 运营 站长

特色栏目 视频下载 织梦模板 教程书籍 职业生涯 正能量 美图

当前位置: 程序人生if98 > 学建站 > cms技巧 >

Discuz!应用中心安装模板提示版本号不匹配的解决方法收藏挑错

2018-07-27 11:23 采编:程序人生 阅读 投稿赚币
有时候我们从应用中心安装模板,在应用中心里模板作者设定允许我们的程序版本,但是我们安装时却提示版本号不匹配,那这是为什么呢?经过我们分析发现是因为X3和X3.1,X3.2的模板
有时候我们从应用中心安装模板,在应用中心里模板作者设定允许我们的程序版本,但是我们安装时却提示版本号不匹配,那这是为什么呢?经过我们分析发现是因为X3和X3.1,X3.2的模板是完全兼容的,很多模板是在X3的时候发布,而且之前的机制里一直是即使版本号不同,用户依然可以强制安装,但是,从X3.1后期开始,官方自己把自己的规矩改了,用户没有办法强制安装了,很多作者也没有在意这点,而且应用中心模板的审核与发布、更新的周期更让作者们苦等。
下面我们以discuz! X3的qing模板安装在X3.2上为例子讲解。
首先说的是错误提示图,如下图所示,官方发布的升级版版本号还是X2.5的,不过这不影响我们演示:

Discuz!应用中心安装模板提示版本号不匹配的解决方法
我们打开template/qing(其他模板为其他模板的目录)/discuz_style_qing.xml文件,在里面找到X2.5,
如果错误图提示为什么版本就搜什么版本,通常能搜索到至少两处
修改成自己的版本然后保存,重新在后台,界面,风格设置处安装模板即可。
相关标签:
程序人生if98.com,专注IT人成长、所需、职场,欢迎参与撰稿、分享资源!

扫一扫关注程序人生公众号

免责声明:本文内容由[程序人生]用户自行发布或编辑转载,本站不拥有所有权、不承担相关法律责任。 如发现有涉嫌抄袭的内容,可邮件 web@if98.com 举报,并提供证据,一经查实,本站将立刻删除涉嫌侵权内容。

发表评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
评价:
表情:
用户名: 验证码:点击我更换图片

站长推荐文章

阅读排行

论坛信息推荐 更多 >>

关于我们

微信公众号

扫码关注官方微信

返回顶部